読者です 読者をやめる 読者になる 読者になる

@ledsun blog

Hのキーがhellで、Sのキーがslaveだ、と彼は思った。そしてYのキーがyouだ。

SandboxMouseEventが見つかりません。FlexBuilder3.0.2へのアップデート方法

FlexSDKのバージョンが低いとコンパイルエラーが出る

FlexSDKのバージョンが3.0の場合、以下のエラーが出てFlexBuilderでのコンパイルが出来ないことがあります。

1061: 未定義である可能性のあるメソッド deployMouseShields を静的型 mx.managers:ISystemManager の参照を使用して呼び出しました。
1061: 未定義である可能性のあるメソッド getSandboxRoot を静的型 mx.managers:ISystemManager の参照を使用して呼び出しました。
1120: 未定義のプロパティ SandboxMouseEvent へのアクセスです。
1172: 定義 mx.events:SandboxMouseEvent が見つかりません。


パッケージについてるDVDからインストールするとSDKのバージョンが3.0なのでこのようなことが起きます。

対策 - FlexSDKを3.2にアップデート

Adobe - Adobe Flex ダウンロードからFlexBuilderのアップーデータを入手し、FlexSDKを3.2にアップデートすると解消できます。
ちなみにHome Project for Open @ Adobe / Home / ProjectsからSDKをダウンロードするとチャートが使えないので注意してください。